Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

Latest Forum Threads in Service-Oriented Architecture (SOA) and SAP

older | 1 | .... | 5 | 6 | (Page 7) | 8 | newer

    0 0

    Hi

     

    I am trying to  consume Webservices of external WSDL url http://202.83.160.22/WS-crpl-9001/ws-crpl-9001.asmx?wsdl  in sap which is located outside the  local sap network, When i tried to create client proxy by going to se80 and after completing the required steps it gives me error of Exception occurred in communication framework:Error in HTTP Framework:404conn,

    Its Been a two week that i am trying to figure out this error  I already posted the question on Scn last week but no body bothers to answer me,

    I tired All suggestion and way out that different sites suggest like by going on to tocde Sicf -> client ->proxy setting ->https log and give the host name and port no of system where these wsdl file actually located, I also tried to save this url  locally  on my desktop and then I gives me error of Exception occurred in library handler Incorrect value: Unknown Namespace http://www.w3.org/2001/XMLSchema

     

    Please Please help me I have done lot of search spent lot of nights to figure it out but couldnot be able to fix please give some way to solve this issue as I am in a real trouble

     

    Waiting for your Responses.

     

     

    Regards


    0 0

    Hi all,

     

    I have many problem with soamanager.

    After an upgrade to EHP7 (SAP_BASIS 740), some endpoint of my web services is not more available.

    I tried to delete/recreate these endpoints but the system give my an error SRT_WSP 580: SRT Framework exception: Error: Register application failed: Application Error: Object already exists: 200.SystemName.XXX.SystemNumber.00xxxxxx00.SystemH

     

    My records shows that in Service Registry -> Publishing System there is no publishing systems defined!

     

    Any help?

     

    Thanks in advance,

     

    Francesca


    0 0

    I have created webservices in SE80 using the Wizrad in DEV. An Entry is created in SICF for the service,

    I have transported this to QAS. This Service entry shows up in SE80 but not in SICF. In SOAMANGER I'am able to use to test the it as well after creating an entry there in QAS.

    For me use this Webservice from .NET I need this entry in SICF so, back in DEV I right click my SICF entry and create the transport entry, I also created an External Alias and the transport entry for the External Alias. When This was transport to

    QAS the external entry was transported to QAS but not the SICF Entry, When I click on the External Alias in QAS I get

    an error Target service not available - repair table Message no. SR053


    0 0
  • 04/12/16--03:15: Web Service
  • I have data in internal table . I want send this data to another program from SAP system. Can you help me? What I must do for sending data with web service . I must function module create?


    0 0

    HI,

     

    I encountered the following error when trying to consume a webservice and create a proxy through SE80:

     

    Exception occurred in communication framework:Error in HTTP Framework:404conn failedhttp://hostname.com/CorpWebServices/Details.asmx?wsdl

     

    Exception of class CX_SLIB

     

     

    Please help me in solving the same.

     

    Regards,

    Madhu


    0 0
  • 04/14/16--08:46: Delete Web Service
  • I created several web service for test. Now I want delete these web services. How I can delete  ?

    When I delete gives an error message as below.


    0 0
  • 04/17/16--06:24: web service error
  • hello,

     

    I am trying to test standard SAP web service.

     

    employeemasterdatareplicationr_OUT

     

    1. I tried it from SOAPUI tool with the WSDL file,

    SRT: Plain SOAP: Reliable messaging (RM) configured, but no Message ID and no WSRM assertion provided.

     

     

     

    2. I tried test  from SOAMANAGER then I am getting following error -- (button "open web service navigator for selected binding")


    http://host:8001/sap/bc/srt/wsdl/flv_10002A1111D1/bndg_url/sap/bc/srt/scs/sap/employeemasterdatareplicationr?sapclient=100/ws/simple/getEmployeeMasterDataReplicationConfirmation_Out

     

    then it routing to wsnavigator and getting 404 error.

     

    3. WS Navigator is not working from SAP.

    http://hostname:50000/wsnavigator  - this is also not working 404 error.



    Can you please let me know how tot resolve these errors?


    Regards,

    Khaja.


    0 0

    My latest work is in intergrating Magento with SAP. Their frontend is in Magento. Suppose, for creating a customer, we need customer name and other details. These details will be coming from magento. I have created a webservice definition from bapi bapi_customer_createfromdata1.

     

    What are the steps I needed to configure in SOA Manager? If you have any notes and ideas, please share.


    0 0
  • 04/20/16--23:22: WS Navigator not working
  • Hello,

     

    I cannot test web service using WSNAVIGATOR.

    WS Navigator is not working from SAP.

    http://hostname:8001/wsnavigator  -  not working 404 error.

    i am getting the following error. can you please let me know how to solve this error?

     

    Service cannot be reached


    What has happened?

    URL call was terminated because the corresponding service is not available.

    Note
    The termination occurred in system with error code 404 and for the reason Not found.

     

    What can I do?

    Please select a valid URL.

     


    HTTP 404 - Not found

    Your SAP Internet Communication Framework Team


    0 0
  • 04/21/16--01:56: call from SOAPUI error
  • hello,

     

    I am getting following error when I call ECC web service from SOAPUI to ECC.

     

    this error I am getting in ECC->SOAMANAGER->Web Service Utilities: Error Log->

     

    SRT: Plain SOAP: Reliable messaging (RM) configured, but no Message ID and no WSRM assertion provided.

     

     

    I found one solution from this SRT: Plain SOAP: Reliable messaging (RM) configured, but no Message ID and no WSRM assertion provided.

    but when I added the ${=java.util.UUID.randomUUID()} code in wsdl file also I am getting the same error.


    I found  another block Plain SOAP: Reliable messaging (RM) configured, but no Message ID and no WSRM assertion provided

    - this one also telling about  - Reliable Messaging: Switch off the RM in the corresponding radio-button. - but I cannot change this as because this is auto generated service. Can you please let me know how to solve this?

     

     

    Regards,

    Khaja.


    0 0

    Hello.

     

    i had configured the SRT Runtime according to SAP manuals.
    All tests in SRT_TOOLS and SOAMANAGER seems to be ok and without errors.

     

    When i try to call a webservice provider from an external consumer i always get http 503 error.

    But there is no webservice isolation active.


    I had tried SRT_TEST to run some tests. But here i get errors.


    E.g. when using the simple Ping test then i get a Service Ping error saying that

    there is some processing error.


    For another testcase i get SOAP:1023 SRT: Processing error in ICF when sending...


    What maybe the reason for these errors in SRT Framework and for the 503 error.

     

    But the same tests running properly on the testsystem.


    Thanks a lot for your ideas and input :-)

     

    Best regards,

    Sebastian Hockmann


    0 0

    Hi,

    For one of my client, We need to call an external web service from ABAP program. So I was trying to create a consumer proxy using the SE80 by passing the URL that was provided by the external service. But at the end I get this error message "Exception occurred in communication framework:Error in HTTP Framework:500Internal Server Error < URL>"

     

    Are there any prerequiste that I should check before creating consumer proxy?

    If so please list down the steps that I need to do.

     

    Really appreciate the help and inputs.

     

    Thanks,

    Srikanth


    0 0
  • 05/08/16--01:34: Parsing soap:Body failed
  • hello,

     

    I am getting the error "Parsing soap:Body failed". Even payload also not coming while we click payload button in tocde srtutil.

    after that I got another like error.

    "Authentication failed (Method wsse:UsernameToken, SRTUTIL Transaction Id 5725A3C3E6290920E10000000AC9140A)"

     

    I created web service in SOAMANAGER and binding, i trigger it from SOAPUI tool then I am getting this error for inbound interface.

    Any idea how to resolve this issuse?


    0 0

    Hi All,

     

    We have created a consumer proxy in SAP ECC using WSDL link in our DEV system. Also created logical ports in SOAMANAGER in DEV system and it works perfectly. We transported our changes to TST system and in TST system we are creating logical ports using the same link that we used in our DEV system, but I am facing this error message:

    "Error: Uninstantiated object "binding operation node" in method IF_SRT_WSP_CONFIG_REGISTRY~CREATE_RT_CFG_FROM_WSDL of class

    CL_SRT_WSP_CONFIG_REGISTRY".

     

    Did anyone come across this error message?

     

    Thanks in advance,

    Karuna


    0 0
  • 05/17/13--02:35: Standalone ESR
  • Hi,

     

    We have a SAP ECC 6.0 landscape and will be integrated using a non-SAP middleware. We are planning to develop all our interfaces as web services based and need to use SAP ESR as modeling tool. I have found out that ESR can be installed standalone on NW Java stack. Also, we want to use standard enterprise services after doing some enhancement.

     

    So, i need to find out whether it is possible to enhance standard enterprise in standalone ESR or do we need PI for enhancing the services?

    Also, let me know if you have any inputs (pros/cons) on this architecture of having standalone ESR connected to SAP ECC Development for modeling purposes.

     

     

    Thanks,

    Vinod


    0 0

    There are many standard webservices and we can also create a webservice for a RFC enabled Function module..


     

    But Issue is coming when we are trying to consume that web service through WSDL in DotNet. It returns the same XML file which is through

    WSDL and doesnot return values for it in response.

     


    Now as WSCONFIG and WSADMIN are Obsoulete(Cant be used)... We are using SOAMANAGER Transaction.. But what we found on many sites are old versions of Transaction SOAMANAGER.

     


    Can any one help on how to consume this for fetching the values as response for the given request in XML.

     

     

     

    Also Other Question was regarding configuring a reverse Proxy for Webservice. As Our server IP is not public and we have configured Reverse Proxy . How this is to be configured for webservice.

     

     

     

    Thanks and Regards

     

    Sushil


    0 0

    Dear Gurus,

     

    I need your help to understand the cause of this error.

     

    My requirement is to access webservice created in .Net system and read the data in SAP and return back few data to .Net again.

     

    I tried creating proxy class in Enterprise services (SE80) by following the steps below:

     

    1. Choose Enterprise services -> Click proxy -> Create a proxy with namespace 'Z'.

    2. I got a wizard step, the .Net team gave me a URL (http://10.161.3.42/...../.....asmx

    3. I selected the URL option and gave local object and clicked on complete

    4. It run through progress indicator (read and analyze WSDL document) and I got this error and hence proxy didnot get generated

     

    Error message : Incorrect value: Entity "<<document>>"(60 /2931 ). end tag 'ul' does not match begin tag 'p'

     

    I was not sure if this error was due to the code in .Net. When I checked with the .Net person, he told me that there was no code inside. I am not sure. Any clue on y this error has occured?

     

    Thanks for all your time and support to me on this.

     

    Thanks

    Shanthi


    0 0

    Hi Guys,

     

    I have a newly created web service that works internally in SAP:

    Untitled4.png

     

    Then I made a new entry in transaction STRUST with my certificate:

    Untitled3.png

     

    I have found my web service in soamanager and I have generated my WSDL to acces it from soap ui

     

    Untitled2.png

     

    Unfortunately, I cannot seem to access this web service from soap ui and if I look into the SSL Info, it seems to be using another SSL Certificate (another existing certificate from SSL Server Standard in STRUST). How could I force the consumer to use my certificate instead of another one?

     

    Untitled5.png

     

    Thank you in advance for your answers!


    0 0

    Hi all,

    I am trying to call a vertex web service through SAP.

    Now, when i try to execute the client proxy with SAP, i get the message "Call Successful-Empty Result".

    But When, i try to send the same request through XMLSpy/SOAP UI, I am getting relevant results back.

     

    When i looked into SM59 for the corresponding HTTP Destination, the connection test returned status code 415.

    When i ran transaction SXMB_MONI, i got no results.( Note: We don't have a PI System)

     

    Kindly, help me out on this.

     

    Thanks

    Sahil


    0 0

    Hi,

     

     

    I want to use soamanager transaction, I activated the SICF and includes the parameter icm / host_name_full but after including User and password generates the attachment mistake.

     



    Anyone had this error?

     

     

     

     

    Tks,

     

    Renato


older | 1 | .... | 5 | 6 | (Page 7) | 8 | newer